NETGEAR Warns of Router Security Vulnerability

By

NETGEAR recommends downloading the latest firmware as soon as possible.

Network hardware giant NETGEAR is urging users to update several router models to address a known pre-authentication buffer overflow vulnerability, reports Jonathan Grieg.

According to researchers, Grieg says, the vulnerability “could allow hackers to install malware or carry out a number of other malicious activities.”

“NETGEAR strongly recommends that you download the latest firmware as soon as possible,” Grieg says. Users should visit NETGEAR Support, type their router model number into the search box, then download and install the most recent firmware.

Read more at The Record.

01/03/2023
comments powered by Disqus